解决 Ubuntu 19 安装openjdk 8后与openjfx不兼容

By | 2019年8月26日

小淘气放假了,孩子在上幼儿园的小朋友,报班也不能太变态嘛, 还是让他自己娱乐的时间多一点,但是现在在家的娱乐就是看电视,听说电视看多了越看越傻,就想方设法的给他找一点娱乐活动,把我闲置的树莓派给他装了一个restropie的游戏系统,下来了一堆模拟游戏,但是出人意料的是,竟没有多大的兴趣玩,我想一个是游戏本身对于幼儿园的小朋友还是有点难度,其次是现在的小朋友接触手机平板太多了,对游戏的概念已经完全不是一个档次,对画面、操控方式都有了很大的提高,就像吃惯了肉的人,你给他吃蔬菜,多少还是不喜欢的。

minecraft 无法运行

前两天看邻居的小朋友在玩minecraft,小家伙也很感兴趣,正好我电脑上装过minecraft,但是按照以前的安装方法提示openjfx无法使用。

sudo apt-get install openjdk-8-jre
sudo apt-get install openjdk-8-jdk
sudo apt-get install openjfx

因为系统刚升级了ubuntu 19版本,所以查看了openjfx默认安装是11的版本(安装的是java8),所以无法与java版本配套。
但是minecraft又要求不能使用11版本,所以只有考虑怎么在ubuntu上安装java8

ppa安装 java

网上另外一种方法是 通过ppa安装java

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer

这种方案好像现在也不行了,提示该地址的内容已经失效,应该是对低版本的java已经不再支持。

ubuntu社区 的答案

在网上查找国外用户也出现了这种情况,分析的原因也是因为版本升级造成的,解决的方法是添加旧的源,安装较低版本的openjfx就可以了,问题链接
但是由于国外源的问题,我更新了半个小时都还没更新完,停止,把源换成国内的源,1分钟搞定。

添加源: deb http://mirrors.aliyun.com/ubuntu/ bionic universe

sudo apt install openjfx=8u161-b12-1ubuntu2 libopenjfx-java=8u161-b12-1ubuntu2 libopenjfx-jni=8u161-b12-1ubuntu2

发表评论